Upgrading Joomla 3.2.x to 3.2.4

Today I tried to upgrade my local Joomla site from Joomla 3.2.1 to Joomla 3.2.4 using Joomla_3.2.x_to_3.2.4-Stable-Patch_Package.zip and Voilà I got this error message on my Joomla admin page: Fatal error: Class ‘FOFUtilsObject’ not found in /joomlapath/libraries/fof/model/model.php on line 23. Then I tried to open the Joomla admin page using different browser and I got the Joomla: An error has occurred error message. So I try to fix this error using the technique described in my previous post  and I know the source of the problem is :

so I try to check the directory permission of /joomlapath/libraries/fof/platform/integration folder and I got: 

ok so I just need to chmod 755 integration/ and I thought everything will be OK. And I try to refresh the Joomla admin page and I got a new error message:

Something is not right in here why there are so many error when upgrading Joomla 3.2.1 to Joomla 3.2.4? and you will know why this happen after you check all directory permission in Joomla_3.2.x_to_3.2.4-Stable-Patch_Package.zip

As you can see all these folders do not have read and execute privileges, so all you have to do is run this command:

And copy all folders and files to your Joomla 3.2.x folder 

Leave a Comment

Your email address will not be published. Required fields are marked *